运行.py提示zsh:权限不够的解决方法

运行.py后缀文件时提示“zsh:权限不够”,这是由于该.py文件没有添加可执行权限的原因,码笔记分享.py添加可执行权限的方法:

.py添加可执行权限的方法

执行.py文件时提示如下所示:

解决方法,为test.py文件添加可以执行权限:
使用命令:chmod +x 文件名.py

添加可执行权限后,再重新执行命令./test.py,重新运行.py文件即可正常运行。

2021云服务器又降价了,阿里云VS腾讯云
云服务器特价:2021阿里云服务器优惠活动(全网最低价)
①真便宜:阿里云服务器69元1年,203元3年(全网最低价)
②腾讯云:腾讯云服务器秒杀特惠88元一年起(有高配)
③代金券:2021阿里云代金券一键领取中